Startup Fails on Setting Date via NTP

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Larryd
Posts: 2
Joined: Sun Aug 04, 2019 7:40 pm
Has thanked: 0
Been thanked: 1 time

Startup Fails on Setting Date via NTP

Post by Larryd » Mon Aug 05, 2019 12:41 pm

Startup Fails on Setting Date via NTP..Then name server cannot be used..Then non recoverable failure in name resolution.
GhostBSD version 19.04. Installed in VMware Workstation 15 as a virtual machine.

The install went perfectly and first reboot worked perfectly and startup went to the Mate Desktop but after the next
restart we are stuck at the shell. We can login to the shell and run startx and system continues to the Mate Desktop.

Have done google searches and read some Freebsd troubleshooting for the same errors but so far no solution to this issue.

Any recommendations would be appreciated.
These users thanked the author Larryd for the post:
LargoExpress (Wed Aug 14, 2019 1:23 am)
Rating: 50%

LargoExpress
Posts: 2
Joined: Tue Jul 16, 2019 5:33 pm
Has thanked: 3 times
Been thanked: 1 time

Re: Startup Fails on Setting Date via NTP

Post by LargoExpress » Wed Aug 14, 2019 1:22 am

Can confirm. NOT user-error.

User avatar
ericbsd
Developer
Posts: 1440
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 55 times

Re: Startup Fails on Setting Date via NTP

Post by ericbsd » Wed Aug 14, 2019 8:15 am

The ntpd service start before the network is started, we will need to fix this on the TrueOS side.
These users thanked the author ericbsd for the post:
LargoExpress (Thu Aug 15, 2019 2:22 am)
Rating: 50%

Georgiaboy
Posts: 45
Joined: Mon Nov 04, 2019 6:51 pm
Has thanked: 0
Been thanked: 0

Re: Startup Fails on Setting Date via NTP

Post by Georgiaboy » Thu Nov 07, 2019 9:59 pm

Can I tag in on this? I'm having basically same issue. Was working good last night. Then while trouble shooting for the enigmail I had noticed that I had both gtk2 and gtk 3 installed referring to GIMP with the first being old and second current. So removed. Then saw that LO was gone. Reinstalled and rebooted. From then on I've been getting this error on startup and it going to the tty screen to login. Here's the error message that's basically the same thing.

Name server cannot be used: non-recoverable failure in name resolution
Error resolving pool0freebsd.ntp.org:non-recoverable failure in name resolution

I've been trying to search and look up fixes for this and noticed that this is about same issue. Any help would be greatly appreciated. If this isn't the same issue then please advise and I'll start a new post. Just didn't want to start a new one and be told that there's already one started on the issue.

I'm using the Mate version of GhostBSD.
Thanks

Georgiaboy

Georgiaboy
Posts: 45
Joined: Mon Nov 04, 2019 6:51 pm
Has thanked: 0
Been thanked: 0

Re: Startup Fails on Setting Date via NTP

Post by Georgiaboy » Thu Nov 07, 2019 10:10 pm

Additional information.
I just did a startx and it did boot up to the system. I see that LO is reinstalled now. But will need to reinstall FF and TB. No biggie . At least got there. But still looking to see what a permanent fix is for the issue.

Again, any help is greatly appreciated.

Georgiaboy

User avatar
ericbsd
Developer
Posts: 1440
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 55 times

Re: Startup Fails on Setting Date via NTP

Post by ericbsd » Fri Nov 08, 2019 8:10 am

The NTP problem is related to the network not being up on time for ntpd. As soon I have a solution for that, I will send an update.

To sync the time you can do

Code: Select all

sudo service ntpdate restart
@Georgiaboy look like you broke your installation, removing default packages can result in removing a lot of packages. Looks like lightdm is not working for you is it missing?

you can try to replace DHCP by SYNCDHCP in your network config in /etc/rc.conf like

Code: Select all

ifconfig_igb0="DHCP"
ifconfig_igb0="SYNCDHCP"
Or set up a static IP

Code: Select all

ifconfig_igb0="inet 192.168.0.10 netmask 255.255.255.0"
defaultrouter="192.168.0.1"

Georgiaboy
Posts: 45
Joined: Mon Nov 04, 2019 6:51 pm
Has thanked: 0
Been thanked: 0

Re: Startup Fails on Setting Date via NTP

Post by Georgiaboy » Fri Nov 08, 2019 6:54 pm

@ericbsd
Thanks for the information. I'll be giving this a shot. I thought that they were related but sometimes when I've been troubleshooting on my own and doing a mountain of research my brain gets kinda fried and I just wanted to make sure I wasn't tagging in on something that I actually needed a new post for. Sometimes in this one forum I'm a member of its a game of 'hi-jack thread time' for about five or so posts and then back to the original posts. But we only do it on certain people that we have fun with. :lol:

So when I get to userland I just su and su - then do a #service ntpdate restart to correct that part of the issue right?
Not sure if the dm is missing. But then I've not been able to get to the userland except by tty. I have noticed though that if I step away from the laptop a bit and don't get to the screen in time I do have some sign in block with a clock on it. Not the original sign in block that was showing when I installed it.

I've never heard of the SYNCDHCP before. That sound interesting to me. How does this work?

Dumb question about the static IP. Doesn't the IP provider change the IP's at times? If I set that up as a static wouldn't that maybe mess things up if they do an IP change? Just curious because someone told me years ago that that IP providers often changes the IP addresses.

I can remember when working on copiers at this one location that we would have to change the IP addresses on them to static because if it wasn't done those things would go out and change IP address on their own and then nobody could print to them. :lol: :lol:

User avatar
ericbsd
Developer
Posts: 1440
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 55 times

Re: Startup Fails on Setting Date via NTP

Post by ericbsd » Fri Nov 08, 2019 8:17 pm

The static IP only affects your router network, not your external IP.

So if I understand well you never got to the DM login UI?

if so you can run

Code: Select all

cap_mkdb /etc/login.conf
maybe it will bring the dm on reboot.

Georgiaboy
Posts: 45
Joined: Mon Nov 04, 2019 6:51 pm
Has thanked: 0
Been thanked: 0

Re: Startup Fails on Setting Date via NTP

Post by Georgiaboy » Fri Nov 08, 2019 9:38 pm

ericbsd wrote:
Fri Nov 08, 2019 8:17 pm
The static IP only affects your router network, not your external IP.

So if I understand well you never got to the DM login UI?

if so you can run

Code: Select all

cap_mkdb /etc/login.conf
maybe it will bring the dm on reboot.
Ok, I did the mkdb/ect.loedgin.conf command. Rebooted. Still getting the error and going to tty0 and having to use startx.
How long does it take for the service ntpdate restart to complete it's action? Reason I'm asking is that it shows the logging out of the ntp redoing everything and then shows it starting back up and just sits there with an hour glass in the cli. It shouldn't take that long right??

Georgiaboy
Posts: 45
Joined: Mon Nov 04, 2019 6:51 pm
Has thanked: 0
Been thanked: 0

Re: Startup Fails on Setting Date via NTP

Post by Georgiaboy » Fri Nov 08, 2019 9:51 pm

@ericbsd
This is what I'm trying to explain about.

Code: Select all

root@son-of-venus:~ # service ntpdate restart
 * Stopping ntpd ...                                                      [ ok ]
 * Setting date via ntp.
 8 Nov 18:41:17 ntpdate[4042]: adjust time server 208.79.89.249 offset -0.019257 sec
root@son-of-venus:~ #  * Starting ntpd ...                                [ ok ]
It just sits there with the mouse showing as an hour glass forever. Doesn't go back to the root just stays in that one spot.
I'm assuming that it's completed the restart. But it still gives the error and boots into the tty.
Well, I did the bit about changing out the DHCP to SYNCDHCP. Had commented out the line for DHCP and then added the SYNCDHCP. Boy were there a lot of errors about not finding DHCP. :) But got to the tty as usual and then startx.into the userland. Guess I'll just have to do that until your update comes in for this. Man, do you really keep busy don't you??

Post Reply