Please read this before upgrading to 22.06.07

News and Announcements related to GhostBSD
Post Reply
User avatar
ericbsd
Developer
Posts: 1971
Joined: Mon Nov 19, 2012 7:54 pm

Please read this before upgrading to 22.06.07

Post by ericbsd »

There is a problem with upgrading the system-config-printer.

The error is as follows:

Code: Select all

[1/23] Extracting system-config-printer-1.5.12_2:   3%
pkg: Fail to create temporary file: /usr/local/lib/python3.8/site-packages/cupshelpers-1.0-py3.8.egg-info/.pkgtemp.PKG-INFO.gJdjcIc8ZNWR:Not a directory
[1/23] Extracting system-config-printer-1.5.12_2: 100%
It is also a known issue on the FreeBSD project. Here is the FreeBSD Bugzilla ticket https://bugs.freebsd.org/bugzilla/show_ ... ?id=264445.

I recommend deleting the system-config-printer and reinstalling it before starting the upgrade. You can reinstall it after the upgrade fails, but the error message in Update Station is not shown due to a bug.

As root, run this command line:

Code: Select all

pkg delete system-config-printer ; pkg install system-config-printer
I am sorry for the inconvenience. I will be working on adding code to mitigate these upgrade issues with Update Station So that users don't have to deal with that.
Morty
Posts: 25
Joined: Mon Sep 20, 2021 8:22 am

Re: Please read this before upgrading to 22.06.07

Post by Morty »

All is well.Thanks,ericbsd! :D

❯ ghostbsd-version -kofv
1301502
22.05.31
13.1-STABLE
22.06.07

~
❯ sudo pkg audit -F
Password:
vulnxml file up-to-date
0 problem(s) in 0 installed package(s) found.

~ took 6s
Post Reply