What gstreamer plug in needed?  [SOLVED]

Support with sound and multimedia cards on GhostBSD

What gstreamer plug in needed?

Postby frogprince » Sun Sep 17, 2017 10:24 pm

I know, it's weird music, but I like to listen to it now and then. I've added HBR1 - Dream Factory to both Goggles and Exaile. The station has a choice of either AAC+ or Oggvorbis encoding. I've installed the gstreamer "bad" plugin among others, but in both cases, the players give me an error message stating that they don't have the correct plug in. AAC is supposed to be included in the gstreamer "bad" one; does anyone know what I need?
Thanks in advance.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.
frogprince
 
Posts: 35
Joined: Mon Jul 10, 2017 8:50 pm
Has thanked: 7 times
Been thanked: 3 times

What gstreamer plug in needed?


Re: What gstreamer plug in needed?

Postby NevilleGoddard » Mon Sep 18, 2017 7:28 am

Oggvorbis should work fine. I think I had a similar problem. Ogg files wouldn't play.
These are the plugins I have:

gstreamer-plugins-vorbis
gstreamer1-plugins-vorbis

gstreamer-plugins-ogg
gstreamer1-plugins-ogg

Then Oggvorbis should work.

For AAC you may need:

gstreamer-plugins-faac
gstreamer-plugins-faad
gstreamer1-plugins-faac
gstreamer1-plugins-faac

also the faac and faad2 packages. These should already be installed.

To install needed plugins, open Octopkg and enter ogg, vorbis, AAC separately in the search box and you may get an idea of what is missing on your system.

After installing the plugins, you may need to restart Exaile for them to start working.
NevilleGoddard
Developer
 
Posts: 338
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 73 times
Been thanked: 43 times

Re: What gstreamer plug in needed?  [SOLVED]

Postby frogprince » Tue Sep 19, 2017 11:00 am

This appears to be a player software problem. I added the gstreamer ogg, vorbis, and aac plugins in addition to the gstreamer 1 versions. I can now play somafm and HBR1 streams on Firefox and Rythymbox. On Exaile, I can now play the HBR1 streams, but not somafm, my other online favorite. On that player, I get an error message stating "No suitable plugins found", perhaps because soma uses a playlist format (*.pls). On Goggles, which I like because it is so light, I can play somafm, but not either of the HBR1 streams. Since I can play all three streams on Rythymbox, I assume that there is now no plugin problem. Why Exaile and Goggles will not open those streams is above my pay grade.

Thanks for the quick response! My workaround is to simply use Rhythmbox.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.
frogprince
 
Posts: 35
Joined: Mon Jul 10, 2017 8:50 pm
Has thanked: 7 times
Been thanked: 3 times


Return to Sound Device

Who is online

Users browsing this forum: No registered users and 0 guests

cron