BSD Randomly Halts on Boot

Share your ideas, questions or suggestions with us here.

BSD Randomly Halts on Boot

Postby frogprince » Tue Sep 05, 2017 10:21 am

My BSD machine has removable hard drives, and I run both 10.3 and 11.1 on the same machine. With a fully updated 11.1, the boot process randomly halts at:

Code: Select all
cd0 at ata5 bus 0 scbus 5 target 0 lun 0


I don't see this behavior with 10.3 on the same machine. Has anyone else seen this behavior? Should I take this issue to the FreeBSD forum?
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.
frogprince
 
Posts: 35
Joined: Mon Jul 10, 2017 8:50 pm
Has thanked: 7 times
Been thanked: 3 times

BSD Randomly Halts on Boot


Re: BSD Randomly Halts on Boot

Postby kraileth » Wed Sep 27, 2017 11:31 am

frogprince wrote:I don't see this behavior with 10.3 on the same machine. Has anyone else seen this behavior? Should I take this issue to the FreeBSD forum?


Yes. That's still fairly early in the boot process while the kernel detects the hardware. GhostBSD runs a unmodified FreeBSD kernel and thus you should hit exactly the same behavior if you try it out with a mainline FreeBSD 11.1. If you do (what I absolutely would expect) it's something that needs to be resolved in upstream FreeBSD since we're only consuming it as the base for our distribution. But thanks for reporting! Things like that should be figured out and fixed.
kraileth
Developer
 
Posts: 305
Joined: Sun Sep 04, 2016 11:30 am
Has thanked: 57 times
Been thanked: 51 times

Re: BSD Randomly Halts on Boot

Postby ASX » Wed Sep 27, 2017 11:39 am

Hate when things show out some randomness :evil:
Computers are supposed to strictly follow what they are instructed to do, not behave randomly. :mrgreen:
ASX
Developer
 
Posts: 970
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 130 times


Return to Feedback

Who is online

Users browsing this forum: No registered users and 2 guests