Skpye won't start  [SOLVED]

Installing and maintaining software with the FreeBSD Ports Collection.
unohu62
Posts: 9
Joined: Wed Jan 18, 2017 9:28 pm
Has thanked: 0
Been thanked: 0

Skpye won't start

Post by unohu62 » Wed Jan 18, 2017 9:33 pm

I can't get Skype to start. It builds from the ports fine but I get this error message in a terminal.

unohu62@ma3a ~> skype
exec: LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so: not found

I also built the libv4l from ports but no joy!

Any ideas would be most welcome.

Thanks
Last edited by unohu62 on Tue Mar 07, 2017 2:36 pm, edited 3 times in total.

kraileth
Developer
Posts: 312
Joined: Sun Sep 04, 2016 12:30 pm
Has thanked: 0
Been thanked: 0

Re: Skpye won't start

Post by kraileth » Wed Jan 18, 2017 11:58 pm

Hi unohu62,

welcome to the forums! I'm not using Skype myself, but I'm guessing that the version that's in ports is geared towards Linux. That's why it looks for v4l2convert.so in /usr/lib whereas on FreeBSD it's installed in /usr/local/lib: That's where libraries of third party packages go - /usr/lib is reserved for programs that are part of the base installation of FreeBSD ("world").

Try symlinking the file and Skype will probably be happy. To do so, open a terminal emulator and type the following commands:

Code: Select all

sudo mkdir -p /usr/lib/libv4l/
sudo ln -s /usr/local/lib/libv4l/v4l2convert.so /usr/lib/libv4l/v4l2convert.so
If that's the only library that Skype is missing you should already be done. But there are probably more. Try running the program again and see. If there are more missing libraries, you can try the following command:

Code: Select all

ldd $(which skype)
If the exectable is called "skype" and it's installed in some directory that's in your $PATH, that should display all the libraries that it's linked agains and you can easily see which ones are missing as well. If the program name's "Skype" or something, change the line above accordingly.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Skpye won't start

Post by ASX » Thu Jan 19, 2017 6:02 am

but I'm guessing that the version that's in ports is geared towards Linux. That's why it looks for v4l2convert.so in /usr/lib whereas on FreeBSD it's installed in /usr/local/lib:
Yes, that's a linux binary, and as such will look for linked libraries in /compat/linux.

Linux binaries cannot link to FreeBSD libraries. The suggested link is not going to work.

I have,'t it installed and running right now, however I'm not sure that LD_PRELOAD is needed at all.

Eric in the past got it running, please wait for his feedback.

kraileth
Developer
Posts: 312
Joined: Sun Sep 04, 2016 12:30 pm
Has thanked: 0
Been thanked: 0

Re: Skpye won't start

Post by kraileth » Fri Jan 20, 2017 1:14 am

Ah, didn't know that it comes as a binary. I've never used it and Microsoft made a lot of their stuff open source over the last couple of years and so I thought that the Client for Skype might be, too. Well, in that case the Linux library is needed in /compat/linux, I guess. But if Eric had it working in the past can probably answer the question what to do to make it work best.

unohu62
Posts: 9
Joined: Wed Jan 18, 2017 9:28 pm
Has thanked: 0
Been thanked: 0

Re: Skpye won't start

Post by unohu62 » Fri Jan 20, 2017 3:32 am

I appreciate your input guys, thanks!

User avatar
ericbsd
Developer
Posts: 1164
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 0
Been thanked: 2 times

Re: Skpye won't start

Post by ericbsd » Sat Jan 21, 2017 9:59 am


ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Skpye won't start

Post by ASX » Sat Jan 21, 2017 10:08 am

ericbsd wrote:unohu62 look at this http://daemon-notes.com/articles/desktop/skype
When I read things like this, I realize that we will not be able to do packaging properly, building a package that depend on hardware configuration (e.g. with or without nvidia video adapter) is going to be broken by default.

Even if this would be addressed in skype port, we will not be able to build a package that works everywhere.

User avatar
ericbsd
Developer
Posts: 1164
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 0
Been thanked: 2 times

Re: Skpye won't start

Post by ericbsd » Sat Jan 21, 2017 10:14 am

Basically, when I install Skype It work out of the box in 11.0, but in 10.3 forget that there is thing missing in the default system.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Skpye won't start

Post by ASX » Sat Jan 21, 2017 10:35 am

ericbsd wrote:Basically, when I install Skype It work out of the box in 11.0, but in 10.3 forget that there is thing missing in the default system.
Hmm ... the port tree is the same for 10.x and 11.x ... something doesn't add up.

quoted from the link you posted:
Linux emulator wants to install OpenGL library which will conflict with NVida's Linux OpenGL library
So, how is that conflict solved in 11.x ?

User avatar
ericbsd
Developer
Posts: 1164
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 0
Been thanked: 2 times

Re: Skpye won't start

Post by ericbsd » Sat Jan 21, 2017 11:11 am

That part I never use that also never had been able to use Skype on 10.3.

The support was annonce for 11.0.

Post Reply