Cannot mount 320gb fat32 format drive via usb  [SOLVED]

Support for other hardware categories not listed below.

Cannot mount 320gb fat32 format drive via usb

Postby madbox » Wed Sep 20, 2017 12:48 pm

Hi!

I've just recently made the switch from Linux to BSD, to get away from all the systemd drama. I learned about GhostBSD after searching around for a bit, and am quite happy with it so far and it has definitely made my switch much easier. But I've still much to learn and have just a few more things yet to sort out.

I'm using GhostBSD 64bit 10.3 with the mate desktop. When I plug an external drive (as mentioned above) into the usb, I receive this:

Cannot Mount Volume
Unable to mount the volume
-Details
mount-msdosfs: /dev/da0s1: Disk too big, try '-o large' mount option: Invalid Argument

BTW I'm using the zfs file system in my GhostBSD install. I have many files that I need to transfer over and I don't know how to proceed past this point.

Thanks.
madbox
 
Posts: 6
Joined: Wed Sep 20, 2017 10:12 am
Has thanked: 0 time
Been thanked: 0 time

Cannot mount 320gb fat32 format drive via usb


Re: Cannot mount 320gb fat32 format drive via usb  [SOLVED]

Postby ASX » Wed Sep 20, 2017 2:52 pm

madbox wrote:Hi!

I've just recently made the switch from Linux to BSD, to get away from all the systemd drama. I learned about GhostBSD after searching around for a bit, and am quite happy with it so far and it has definitely made my switch much easier. But I've still much to learn and have just a few more things yet to sort out.

I'm using GhostBSD 64bit 10.3 with the mate desktop. When I plug an external drive (as mentioned above) into the usb, I receive this:

Cannot Mount Volume
Unable to mount the volume
-Details
mount-msdosfs: /dev/da0s1: Disk too big, try '-o large' mount option: Invalid Argument

BTW I'm using the zfs file system in my GhostBSD install. I have many files that I need to transfer over and I don't know how to proceed past this point.

Thanks.


Hi and welcome!

The correct syntax would be: (i'm mentioning this as I'm not sure what you have used exactly, when posting please always copy&paste the exact command and error you got)
Code: Select all
mount -t msdosfs /dev/da0s1 /mnt


As the mount command itself suggest, try to use the "large" option:
Code: Select all
mount -t msdosfs -o large /dev/da0s1 /mnt


If that would fail too, forget about mounting the filesystem and start to think at something else, but what to use depend if you have another computer available temporarily: if yes, you could use a Linux Live-Media, mount the fat32 partition, and transfer the content via network, using rsync.
ASX
Developer
 
Posts: 970
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 130 times

Re: Cannot mount 320gb fat32 format drive via usb

Postby kraileth » Wed Sep 20, 2017 3:02 pm

[edit: ASX was faster once again ;) But I leave my post here, anyway.]

Hi madbox!

I see that you're another one of us who have been playing the "escape from systemd" adventure. Welcome to GhostBSD and the forums!

So I assume you did something like this:

Code: Select all
mount -t msdosfs /dev/da0s1 /mnt


Correct? Have you tried to add the suggested "-o large" argument? BTW: Make sure to add it before the device node - while the GNU tools are quite lax when it comes to syntax (leading to funky problems that require weird means like -- to end arguments) while BSD is strictly enforcing the clean way of doing things. The "large" option is needed for FAT32 partitions bigger than 128 GB. If it is a partition with an extremely high file count and you have very little RAM this option can lead to problems. Otherwise you should be fine. If you did add it - what happened?

BTW: FAT32 may not be your best choice to copy data over. Sure, both Linux and *BSD can read it, but you lose Unix permissions and file ownership etc. for all your files if you use either FAT or NTFS. FreeBSD will also work well with Linux's EXT2 (and is said to cope with EXT3 except for the journaling, but I haven't ever tried this). The downside of using EXT is that FreeBSD only supports synchronous writes, so copying stuff to EXT is slow. If you just want to copy files from EXT that should be ok, though.

Once you've become familiar with ZFS, you might want to consider that. There's the ZFSonLinux project and if done correctly (minding the pool version as Linux tends to be lacking a little behind), you have an excellent FS that works in both worlds and keeps your data save.

Enjoy GhostBSD - and feel free to ask here whenever you have a problem.
kraileth
Developer
 
Posts: 305
Joined: Sun Sep 04, 2016 11:30 am
Has thanked: 57 times
Been thanked: 51 times

Re: Cannot mount 320gb fat32 format drive via usb

Postby madbox » Wed Sep 20, 2017 5:58 pm

Thanks very much for the quick responses.

When I would plug in the drive into the usb port, it would show up in Caja, but as unmounted. When I used the command listed above to mount large drives, it would immediately remove itself from Caja totally without mounting.

I'm taking kraileth's advice because I have access to another linux machine here, removing the files from the drive and reformatting the drive to ext2. Then I will re-copy the files back to the drive.

I'm still in the process of doing that, so I'll let you know how it goes. Hopefully I will be able to transfer them from a ext2 formatted drive.

Thanks again!
madbox
 
Posts: 6
Joined: Wed Sep 20, 2017 10:12 am
Has thanked: 0 time
Been thanked: 0 time

Re: Cannot mount 320gb fat32 format drive via usb

Postby madbox » Thu Sep 21, 2017 2:09 pm

Update:
I have everything safely transferred over. But some of the important stuff I also burned to dvd's as well. Big thanks again to ASX and kraileth, for the how to load discs and the different file formats.
madbox
 
Posts: 6
Joined: Wed Sep 20, 2017 10:12 am
Has thanked: 0 time
Been thanked: 0 time

Re: Cannot mount 320gb fat32 format drive via usb

Postby kraileth » Thu Sep 21, 2017 2:31 pm

madbox wrote:Update:
I have everything safely transferred over. But some of the important stuff I also burned to dvd's as well. Big thanks again to ASX and kraileth, for the how to load discs and the different file formats.


Glad everything worked well for you now! I'm marking this thread as solved.
kraileth
Developer
 
Posts: 305
Joined: Sun Sep 04, 2016 11:30 am
Has thanked: 57 times
Been thanked: 51 times


Return to General Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron