How to Fix Mouse Scrolling  [SOLVED]

Support for other hardware categories not listed below.

How to Fix Mouse Scrolling

Postby fmh » Tue Nov 28, 2017 11:39 am

This annoying feature came back into version 11.1 of GhostBSD after being away for a couple of releases. Now that I use GhostBSD more it really bothers and I have not been able to find out how to correct it yet. In all versions of 11.1 that I have tried of Mate including Betas etc is that the Mouse Scroll wheel works properly when scrolling down but if you scroll up it is configured as a Backspace key. Behaviour is that when on a Web page instead of scrolling to the top of the page it goes to the previous page. When in other non Web Browser apps or on the Desktop the same thing happens when using the scroll up to get to the top of the list it goes back to the previous page, app, etc.

How do I turn off this behaviour? It was in 10.3 I believe and then was fixed until 11.1. I looked in Mouse and Keyboard settings and can not find where this is configured. I am using 11.1 64bit Mate install.
fmh
 
Posts: 94
Joined: Wed Jul 23, 2014 1:07 pm
Has thanked: 0 time
Been thanked: 2 times

How to Fix Mouse Scrolling


Re: How to Fix Mouse Scrolling  [SOLVED]

Postby ericbsd » Tue Nov 28, 2017 12:48 pm

Remove moused in /etc/rc.conf that is the problem.
User avatar
ericbsd
Developer
 
Posts: 1104
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 30 times
Been thanked: 54 times

Re: How to Fix Mouse Scrolling

Postby slughorn » Wed Nov 29, 2017 2:06 pm

fmh wrote:This annoying feature came back into version 11.1 of GhostBSD after being away for a couple of releases. Now that I use GhostBSD more it really bothers and I have not been able to find out how to correct it yet. In all versions of 11.1 that I have tried of Mate including Betas etc is that the Mouse Scroll wheel works properly when scrolling down but if you scroll up it is configured as a Backspace key. Behaviour is that when on a Web page instead of scrolling to the top of the page it goes to the previous page. When in other non Web Browser apps or on the Desktop the same thing happens when using the scroll up to get to the top of the list it goes back to the previous page, app, etc.

How do I turn off this behaviour? It was in 10.3 I believe and then was fixed until 11.1. I looked in Mouse and Keyboard settings and can not find where this is configured. I am using 11.1 64bit Mate install.

I had the same issue. See here:http://forums.ghostbsd.org/viewtopic.php?f=59&t=928&start=10. The tip of ericbsd has solved my problem. :mrgreen:
User avatar
slughorn
 
Posts: 12
Joined: Mon Oct 02, 2017 1:55 pm
Location: Grimma / Germany
Has thanked: 4 times
Been thanked: 0 time


Return to General Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest