How to use single user mode?

Post your general questions or comments about GhostBSD here!

How to use single user mode?

Postby Harion » Sat Dec 30, 2017 3:40 pm

Hello,

I'm stuck with GhostBSD. It does not log my user anymore (mate session). I know what to do to repair: I just need to delete a line in ~/.xinitrc.

The problem is when I boot in single user mode, it's read-only. Tried "mount -u -rw /" and some variants with no luck. The disk stays in read-only mode.

Any idea?
Harion
 
Posts: 8
Joined: Sat Dec 30, 2017 3:30 pm
Has thanked: 2 times
Been thanked: 1 time

How to use single user mode?


Re: How to use single user mode?

Postby ericbsd » Sat Dec 30, 2017 5:00 pm

When you are at the login you can do Ctrl+Alt+F2, but if you have latest Nvidia card like me you might not work for you like me.

So there is also the single user like you tried.
Code: Select all
mount -u /
/rescue/vi /home/usr/.xinitrc
mount -a
exit
User avatar
ericbsd
Developer
 
Posts: 1122
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 34 times
Been thanked: 60 times

Re: How to use single user mode?

Postby Harion » Sat Dec 30, 2017 6:43 pm

Thanks. You saved my install. The Ctrl+Alt+F2 at the slim login works. Once there, I was able to login as root and I did the job.

However, all I did in single-user mode (including you wrote here) never changed the read-only mode. So, a question remains: what is the utility of single-user mode if it's impossible to mount the system in write-mode to correct the problems?

Thanks again anyway. I have a debt. ;)
Harion
 
Posts: 8
Joined: Sat Dec 30, 2017 3:30 pm
Has thanked: 2 times
Been thanked: 1 time

Re: How to use single user mode?

Postby NevilleGoddard » Sun Dec 31, 2017 9:14 am

Just a guess but I think it's

mount -u /
NevilleGoddard
Developer
 
Posts: 363
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 76 times
Been thanked: 48 times

Re: How to use single user mode?

Postby Harion » Sun Dec 31, 2017 10:45 am

Hi,

I tried "mount -u/" but, as I expected, the syntax is incorrect since '/' isn't a valid option. A space must lie between 'u' and '/'.

Then, I typed "mount -u /" and you know what? It worked. I ever tried that, yet... Something escaped to me (and sorry to make you loose your time about this). For the behaviour is now as the documentation says.

Thanks guys.
Harion
 
Posts: 8
Joined: Sat Dec 30, 2017 3:30 pm
Has thanked: 2 times
Been thanked: 1 time

Re: How to use single user mode?

Postby Hecktor » Wed Jan 17, 2018 9:18 pm

ericbsd wrote:When you are at the login you can do Ctrl+Alt+F2, but if you have latest Nvidia card like me you might not work for you like me.


Not sure if it will be the same for you, but for me, adding this line to the /boot/loader.conf fixed the nvidia issue:
hw.vga.textmode=1
Hecktor
 
Posts: 13
Joined: Thu Dec 21, 2017 2:43 pm
Has thanked: 1 time
Been thanked: 3 times

Re: How to use single user mode?

Postby ericbsd » Fri Jan 19, 2018 11:50 am

Thanks, Hecktor I was not aware of this.
User avatar
ericbsd
Developer
 
Posts: 1122
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 34 times
Been thanked: 60 times


Return to General Questions

Who is online

Users browsing this forum: No registered users and 2 guests

cron