some issues....

Post your general questions or comments about GhostBSD here!
Post Reply
User avatar
xmris
Posts: 4
Joined: Tue Jun 14, 2016 11:56 am
Has thanked: 0
Been thanked: 0

some issues....

Post by xmris » Thu Dec 14, 2017 6:35 pm

Hi,

I have to say I am impressed with the 11.1, out-of-the-box support the radeon gfx
of my AMD APU (A8-7600) (even the latest TrueOS can't detect my APU GFX !)

all good except :
a/ display is not working after suspend, system wakes up (HDDs spinning and power LED goes steady from blinking state) but not the display.
b/ some apps (like xsane and gimp) are missing from the packages, what I can see they are on the FreeBSD packages repo but not on GhostBSD's one, is there any reason that are missing?

thanks in advance...

NevilleGoddard
Developer
Posts: 388
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 1 time
Been thanked: 1 time

Re: some issues....

Post by NevilleGoddard » Fri Dec 15, 2017 8:38 am

I have the same problem (black display) after suspend on GhostBSD11.1 but there was no problems with GhostBSD 10.3. Same with FreeBSD. Suspend/resume doesn't work as well in FreeBSD 11 compared to 10.3.
Try putting in /etc/boot.loader.conf :

hw.acpi.reset_video=1

This may help. But suspend/resume in FreeBSD is pretty flaky.

User avatar
ericbsd
Developer
Posts: 1164
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 0
Been thanked: 2 times

Re: some issues....

Post by ericbsd » Fri Dec 15, 2017 9:32 am

About the missing gimp and Xsane that might be due to the new flavored ports. I am compiling a whole new repository in the hope that it will fix the missing packages.

User avatar
xmris
Posts: 4
Joined: Tue Jun 14, 2016 11:56 am
Has thanked: 0
Been thanked: 0

Re: some issues....

Post by xmris » Fri Dec 15, 2017 10:07 am

thx for the replies, no luck with the video resume , also I was wrong that ghostbsd detected correctly my gfx card, still the xorg runs on vesa driver, btw the TrueOS that I tested (unstable / 12.0) is detecting the correct gfx configuration (kaveri R7) but tests on radeon are failing so system goes back to vesa mode.

From what I understand after reading various posts about FreeBSD, looks like I have to wait till the drm-next 4.9 , it seems the current support (4.7) for APU based gfx is a half-baked work, in the meanwhile I will try setup a FreeBSD 12.0-current , then install the drm-next-kmod from the ports.

Post Reply