11.1 Alpha Video Driver?

Post your general questions or comments about GhostBSD here!

11.1 Alpha Video Driver?

Postby frogprince » Mon Aug 14, 2017 11:36 am

I am running an nVidia GeForce 210 video card on my BSD system. My GBD 10.3 install showed considerable video response delay and tearing with the default video driver (mesa?), all of which cleared up by installing the nVidia 340 driver. My GBD 11.1 install did not; it was much smoother and quicker, and there was no tearing. But Octopkg does not show the nVidia driver as having been installed. What is the default driver on 11.1?

That's all I need to know, thanks in advance.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.
frogprince
 
Posts: 27
Joined: Mon Jul 10, 2017 8:50 pm
Has thanked: 6 times
Been thanked: 2 times

11.1 Alpha Video Driver?


Re: 11.1 Alpha Video Driver?

Postby ASX » Mon Aug 14, 2017 11:54 am

frogprince wrote:I am running an nVidia GeForce 210 video card on my BSD system. My GBD 10.3 install showed considerable video response delay and tearing with the default video driver (mesa?), all of which cleared up by installing the nVidia 340 driver. My GBD 11.1 install did not; it was much smoother and quicker, and there was no tearing. But Octopkg does not show the nVidia driver as having been installed. What is the default driver on 11.1?

That's all I need to know, thanks in advance.


the driver used for nvidia in ghostbsd 11.1 is "nv", most likely improved over previous versions.
That said, I think that nvidia340 is going to give you better performance but didn't tried myself.
ASX
Developer
 
Posts: 942
Joined: Wed May 06, 2015 11:46 am
Has thanked: 53 times
Been thanked: 122 times

Re: 11.1 Alpha Video Driver?

Postby frogprince » Mon Aug 14, 2017 1:39 pm

Thanks! I'd forgotton about the free and open nvidia driver. It works well.. :D ..but I may test it and report back.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.
frogprince
 
Posts: 27
Joined: Mon Jul 10, 2017 8:50 pm
Has thanked: 6 times
Been thanked: 2 times

Re: 11.1 Alpha Video Driver?

Postby frogprince » Wed Aug 16, 2017 11:56 am

I uninstalled nv, and then installed nvidia-driver-340, nvidia-settings, and nvidia-xconfig. /boot/loader.conf did not contain:

Code: Select all
"nvidia_load=YES"


so that remained the same. However, I did have to open as root /etc/rc.conf and add:

Code: Select all
kld_list="nvidia"


I then ran as root:

Code: Select all
nvidia-xconfig


rebooted, and voila! the nvidia driver was running. It was obvious; the fonts were a
bit smaller and sharper, and although nv was no laggard, the OEM driver was
snappier and the overall system more responsive.

Just an fyi for whoever might be interested.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.
frogprince
 
Posts: 27
Joined: Mon Jul 10, 2017 8:50 pm
Has thanked: 6 times
Been thanked: 2 times


Return to General Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron