Unable to Boot after successful install

Questions about the installation of FreeBSD
Post Reply
nicgentile
Posts: 1
Joined: Sun Dec 10, 2017 5:06 pm
Has thanked: 0
Been thanked: 0

Unable to Boot after successful install

Post by nicgentile » Sun Dec 10, 2017 5:19 pm

So,

I have been able to successfully boot to the live DVD 11.1 XFCE on my ancient HP Compaq 6005 Pro and successfully installed with no problem. I have installed 3 times using different partition formats and Grub formats, but even though it is successful after rebooting, it does not boot and remains at "Attempting Boot from Hard Drive". I installed 10.3 on a similar machine with no issues, but for whatever reason it will not stick on this one, or I played around with something, I can't remember.

Anyway, need some help moving to the next step.

Ideas?

Thanks.

wb7odyfred
Posts: 22
Joined: Sat Nov 12, 2016 5:44 pm
Has thanked: 0
Been thanked: 0

Re: Unable to Boot after successful install

Post by wb7odyfred » Mon Dec 11, 2017 5:23 am

Hello. I am copying from another forum post I made here. viewtopic.php?f=64&t=570 Hope these techniques help you debug the none booting behaviour of your GhostBSD 11.1 install from a successfully booted DVD.

# Use wlandebug and sysctl -a | grep wlan to explore settings and debug non-working system problems.

Code: Select all

wlandebug --help
sysctl -a | grep wlan

#Use these commands to debug booting up and loading kernel driver modules. Add "verbose_loading" and "boot_verbose" to file /boot/loader.conf

Code: Select all

boot_verbose="YES"
verbose_loading="YES"
This URL answers the question, "Why is my /boot/loader.conf file not working? https://forums.freebsd.org/threads/7677/ Thanks Dutch for your helpful technique to debug /boot/loader.conf
# Check that you do not have a typo errors in files /boot/loader.conf or /boot/device.hints like a missing "#" tag. The typo error will cause the processing of the file to abort, before completing the following lines in the file. So carefully check the boot logs for error messages or missing loading of device driver kernel modules.

Code: Select all

dmesg -a | less
less /var/run/dmesg.boot

You might have to verify the contents of file /etc/resolv.conf are correct for your internet service provider. At a minimum one nameserver must be correct and possibly one search gateway setup.

Post Reply