Installer not starting X; nvidia vt issues?

Questions about the installation of FreeBSD
Post Reply
dacha
Posts: 4
Joined: Sun Dec 10, 2017 11:42 am
Has thanked: 0
Been thanked: 0

Installer not starting X; nvidia vt issues?

Post by dacha » Sun Dec 10, 2017 12:19 pm

Hi

No matter which Grub option I choose, the installer for GhostBSD 11.1 won't start X11 :(.

It appears that my NVidia GT 620 is unsupported by "nv".

Xorg.0.log transcript:

Code: Select all


(WW) NV: Ignoring unsupported device 0x10de0f01 (GF108 [GeForce GT 620]) at 01@00:00:0
(EE) open /dev/dri/card0: No such file or directory
(WW) Falling back to old probe method for modesetting
(EE) open /dev/dri/card0: No such file or directory
(WW) Falling back to old probe method for scfb
scfb trace: probe start
(II): scfb (1): using default device
scfb trace: probe done
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
(EE) Screen 0 deleted because of no matching config section.
(II) UnloadModule: "modesetting"
(EE)
Fatal server error:
(EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
TrueOS works but it uses a text console. Could that be why? Trying kern.vty=sc however, crashes inside Grub.


Please help?

dacha
Posts: 4
Joined: Sun Dec 10, 2017 11:42 am
Has thanked: 0
Been thanked: 0

Re: Installer not starting X; nvidia vt issues?

Post by dacha » Mon Dec 11, 2017 2:13 pm

I worked around it using the following:

Code: Select all

Xorg -configure
cp /root/xorg.conf /etc/X11/xorg.conf
nano /etc/X11/xorg.conf (and change "nv" to "vesa")
startxfce4
But a real solution is sorely needed for less technical users.

User avatar
ericbsd
Developer
Posts: 1164
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 0
Been thanked: 2 times

Re: Installer not starting X; nvidia vt issues?

Post by ericbsd » Tue Dec 12, 2017 4:31 pm

Probably the Nvidia driver by default could do the job for a newer card.

Post Reply