"error: incompatible license" GhostBSD 11.1 x64 XFCE

Questions about the installation of FreeBSD

"error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Sun Aug 27, 2017 10:40 am

Hi! I asked for help on the chat, but it was almost empty.
I want to install GhostBSD 11.1 Xfce into my old "working-horse" PC (ASUS M2N-E SLI, Athlon 64 x2 3000+ 3.1GHz, 4GB DDR2 RAM and Palit GTS 250 E-Green 1GB). I already have installed Windows 7 x64 and Linux Mint 18.2 Xfce 64 bit. Now I want to install along with the other operating systems - GhostBSD 11.1.
I booted into my Linux Mint and run
Code: Select all
sudo dd if=GhostBSD11.1-ALPHA1-20170808-065822-xfce-amd64 of=/dev/sdb bs=1M
after that I boot into GhostBSD 11.1 flash drive and on GRUB menu I tryed Live mode, Failsafe and others, but all I have is error: incompatible license! What is wrong? I checked image the sum and it was correct.
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

"error: incompatible license" GhostBSD 11.1 x64 XFCE


Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby ASX » Sun Aug 27, 2017 3:02 pm

hi nughost,

I never saw an error like that in more than one hundred installs ... unless something changed lately, I have no clue about what is going on.
Can you try to boot on a different machine (without install) ?
ASX
 
Posts: 988
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 132 times

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Sun Aug 27, 2017 6:33 pm

I haven't yet installed this system, it still on my flash drive.
As you suggested, I will try on other PC, then if still goes wrong I will try other flash drives and version of GhostBSD. I'll write back what I found.
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Mon Aug 28, 2017 11:08 am

I did dd again in Linux Mint 18.2 Xfce 64 bit, bellow the command and the output:
Code: Select all
sudo dd if=GhostBSD11.1-ALPHA1-20170808-065822-xfce-amd64.iso of=/dev/sdb bs=1M conv=sync
2266+1 records in
2267+0 records out
2377121792 bytes (2,4 GB, 2,2 GiB) copied, 372,282 s, 6,4 MB/s


Now I am rebooting to see what I got :)
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Mon Aug 28, 2017 11:25 am

Boot without any problem. I will keep testing GhostBSD 11.1 Xfce Live mode before installing it.
BTW previously I wrote dd from Linux, but the ISO image was at one of NTFS partitions and I didn't used conv=sync. This time I copied the ISO into my Linux Mint /home. Maybe that was the problem.
How do I test if the system I am using right now (GhostBSD Live) was copied without any errors and it is ready to be installed?
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby ASX » Mon Aug 28, 2017 12:13 pm

glad you got it working, have fun! :)
ASX
 
Posts: 988
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 132 times

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Mon Aug 28, 2017 1:14 pm

I tested the Live media I did with Linux dd command and Rufus dd command, both have a same problem - after using running Firefox for some time the systems turns unresponsive! So I hard reboot the PC and did a custom installation - a partition (20GB) previously used by TrueOS, formatted into UFS+SUJ or UFS+J (I'm not sure) and "/" mount point, SWAP partition is the same as used for Linux (is that correct?). Checked GRUB box as well (after installation on OctoPkg I noticed "grub-efi" and "grub-pcbsd", my motherboard does not support EFI/UEFI, is and old BIOS nForce 500).
After reboot I noticed only GhostBSD is bootable, no menu entries of Windows 7 and Linux Mint :( I tried to update GRUB from terminal - sudo update-grub, but it didn't recognised the command "update-grub" :shock: What I did wrong? I can reinstall any time if you point into my errors.
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Mon Aug 28, 2017 2:26 pm

I am able to boot into Windows from Plop manager.
Windows 7 and GhsotBSD are installed on primary partitions. Linux Mint on secondary. My partition table looks something like Windows part 1, Win reserved space part 2, GhostBSD p3, from p4 are made secondary partitions - p5 NTFS, p6 NTFS, p7 Linux Mint, p8 SWAP partition.
I will boot into Linux Mint live usb and see if I can fix GRUB by "update-grub" command.
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby ASX » Mon Aug 28, 2017 3:16 pm

I tried to update GRUB from terminal - sudo update-grub

update-grub is an extra script provided from some linux distro, basically a frontend to grub-mkconfig. ;)
ASX
 
Posts: 988
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 132 times

Re: "error: incompatible license" GhostBSD 11.1 x64 XFCE

Postby nughost » Mon Aug 28, 2017 5:37 pm

ASX wrote:update-grub ... basically a frontend to grub-mkconfig. ;)

Good to know.
I re-installer GhostBSD this time with UFS (instead of UFS+SUJ) and GRUB option. Not helped - the only GRUB entry is the GhostBSD so I re-installed GRUB from Mint Live USB and now I have Linux Mint, Memtest+ and Windows 7 entries but not GhostBSD. Do I have to add it manually on my Linux Mint GRUB "cfg"? What it should look like?
User avatar
nughost
 
Posts: 8
Joined: Sun Aug 27, 2017 10:27 am
Has thanked: 5 times
Been thanked: 0 time

Next

Return to Installing GhostBSD

Who is online

Users browsing this forum: Google Adsense [Bot] and 3 guests