Successful install, unsuccessful upgrade

Questions about the installation of FreeBSD

Successful install, unsuccessful upgrade

Postby descasa » Thu Dec 17, 2015 11:14 am

My laptop -- Lenovo ThinkPad SL400, 4GB RAM, 160GB HDD, Intel Graphics, more details later if needed -- was running GhostBSD 10.1 for a few months. Smooth install, smoother than Windows, about as smooth as Zorin GNU/Linux from what I remember.Those are the two other OSes on my laptop. Also, in contrast to 4.x (?), dual-monitor support worked out of the box, without futzing with xorg.conf, which I had to do with the previous version.

Before I proceed, my apologies in advance if this doesn't belong here. I can read, and I'm aware that this is the section on installing. However, I didn't really know where to put this.

It must've been a week or two ago when a notification popped up on my screen that an update was ready, and would I like to install it. Upgrades are cool so I did. I don't remember the exact nature of the update, think it updated the base OS to 10.2. After a few minutes, a pop-up said that the update was complete, and I would enjoy a new version when I rebooted, which I did.

That's when my problems started. After logging in, I get a blank screen -- actually two, counting my external monitor. Nothing. Couldn't even switch to console with Alt-Fx -- OK, I could, but the screen was still blank. I did manage to type my user ID and password blind, then sudo reboot.

Tried again after a few hours, got the same blank screen upon logon. Thought I'd console myself with some food, which I did, then read newspapers, and when I got back, maybe an hour later, I did get my desktop.

Booted to Zorin so I could put the laptop in sleep mode (not sure it would work in GhostBSD, and I didn't want to try because of issues with my power on/off switch).

Next day, tried to boot into Ghost again, and again got the blank screen when I logged on. Had breakfast, read newspapers, did crossword, but this time my screen was still blank when I went back to it. Frustrated, I switched to a console, logged in, and sudo rebooted, need I remind you, blind.

I'll provide my Xorg.log later, since I tried xorg.conf from my 4.x install and that didn't work either -- in fact it wouldn't even give me the logon screen, and I don't remember if I could switch to a console. I think I ssh'ed into it from my BeagleBone and issued the reboot from there -- but I digress.

Thoughts?
Technologist. Writer and Editor. Shakespearean actor
Google Plus: http://google.com/+DanielEscasa
Twitter: @silverlokk

If we choose being kind over being right, we will be right every time.
descasa
 
Posts: 13
Joined: Wed Jun 11, 2014 6:10 pm
Has thanked: 0 time
Been thanked: 0 time

Successful install, unsuccessful upgrade


Re: Successful install, unsuccessful upgrade

Postby descasa » Thu Dec 17, 2015 2:34 pm

Just tried a few minutes ago. When I tried to log on (gdm?), an ominous graphic informed me that "Something has gone wrong," and that I should "contact (my) System Administrator." Here's my Xorg.0.log:
Code: Select all
[    54.436]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[    54.436] X Protocol Version 11, Revision 0
[    54.436] Build Operating System: FreeBSD 10.1-RELEASE-p24 i386
[    54.436] Current Operating System: FreeBSD Eowyn-Ghost 10.1-RELEASE-p24 FreeBSD 10.1-RELEASE-p24 #0: Mon Nov  2 12:02:13 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC i386
[    54.436] Build Date: 05 December 2015  01:38:28AM
[    54.436] 
[    54.436] Current version of pixman: 0.32.8
[    54.436]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    54.436] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    54.436] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 18 06:13:12 2015
[    54.505] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
[    54.505] (==) No Layout section.  Using the first Screen section.
[    54.505] (==) No screen section available. Using defaults.
[    54.505] (**) |-->Screen "Default Screen Section" (0)
[    54.505] (**) |   |-->Monitor "<default monitor>"
[    54.512] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    54.512] (==) Automatically adding devices
[    54.512] (==) Automatically enabling devices
[    54.512] (==) Not automatically adding GPU devices
[    54.648] (==) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
[    54.648] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[    54.648] (II) The server relies on devd to provide the list of input devices.
   If no devices become available, reconfigure devd or disable AutoAddDevices.
[    54.648] (II) Loader magic: 0x8232070
[    54.648] (II) Module ABI versions:
[    54.648]    X.Org ANSI C Emulation: 0.4
[    54.648]    X.Org Video Driver: 19.0
[    54.648]    X.Org XInput driver : 21.0
[    54.648]    X.Org Server Extension : 9.0
[    54.663] (--) PCI:*(0:0:2:0) 8086:2a42:17aa:20e4 rev 7, Mem @ 0x80000000/4194304, 0xd0000000/268435456, I/O @ 0x00005c00/8, BIOS @ 0x????????/65536
[    54.663] (--) PCI: (0:0:2:1) 8086:2a43:17aa:20e4 rev 7, Mem @ 0xfdb00000/1048576
[    54.663] (II) LoadModule: "glx"
[    54.710] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[    54.868] (II) Module glx: vendor="X.Org Foundation"
[    54.868]    compiled for 1.17.4, module version = 1.0.0
[    54.868]    ABI class: X.Org Server Extension, version 9.0
[    54.868] (==) AIGLX enabled
[    54.868] (==) Matched intel as autoconfigured driver 0
[    54.868] (==) Matched fbdev as autoconfigured driver 1
[    54.869] (==) Matched vesa as autoconfigured driver 2
[    54.869] (==) Assigned the driver to the xf86ConfigLayout
[    54.869] (II) LoadModule: "intel"
[    54.869] (II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
[    54.917] (II) Module intel: vendor="X.Org Foundation"
[    54.917]    compiled for 1.17.2, module version = 2.21.15
[    54.917]    Module class: X.Org Video Driver
[    54.917]    ABI class: X.Org Video Driver, version 19.0
[    54.917] (II) LoadModule: "fbdev"
[    54.925] (WW) Warning, couldn't open module fbdev
[    54.925] (II) UnloadModule: "fbdev"
[    54.925] (II) Unloading fbdev
[    54.926] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    54.926] (II) LoadModule: "vesa"
[    54.926] (II) Loading /usr/local/lib/xorg/modules/drivers/vesa_drv.so
[    54.930] (II) Module vesa: vendor="X.Org Foundation"
[    54.930]    compiled for 1.17.2, module version = 2.3.4
[    54.930]    Module class: X.Org Video Driver
[    54.930]    ABI class: X.Org Video Driver, version 19.0
[    54.931] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
   HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
   HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
   HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
   HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[    54.933] (II) VESA: driver for VESA chipsets: vesa
[    54.934] (--) Using syscons driver with X support (version 2.0)
[    54.934] (++) using VT number 9

[    56.938] (WW) Falling back to old probe method for vesa
[    56.938] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    56.938] (II) intel(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    56.938] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    56.938] (==) intel(0): RGB weight 888
[    56.938] (==) intel(0): Default visual is TrueColor
[    56.938] (--) intel(0): Integrated Graphics Chipset: Intel(R) GM45
[    56.938] (**) intel(0): Relaxed fencing enabled
[    56.938] (**) intel(0): Wait on SwapBuffers? enabled
[    56.938] (**) intel(0): Triple buffering? enabled
[    56.938] (**) intel(0): Framebuffer tiled
[    56.938] (**) intel(0): Pixmaps tiled
[    56.938] (**) intel(0): 3D buffers tiled
[    56.938] (**) intel(0): SwapBuffers wait enabled
[    56.939] (==) intel(0): video overlay key set to 0x101fe
[    56.946] (II) intel(0): Output LVDS1 has no monitor section
[    56.953] (II) intel(0): Output VGA1 has no monitor section
[    56.957] (II) intel(0): Output HDMI1 has no monitor section
[    56.957] (II) intel(0): Output DP1 has no monitor section
[    56.966] (II) intel(0): Output DP2 has no monitor section
[    56.979] (II) intel(0): EDID for output LVDS1
[    56.979] (II) intel(0): Manufacturer: LEN  Model: 4031  Serial#: 0
[    56.979] (II) intel(0): Year: 2007  Week: 0
[    56.979] (II) intel(0): EDID Version: 1.3
[    56.979] (II) intel(0): Digital Display Input
[    56.979] (II) intel(0): Max Image Size [cm]: horiz.: 30  vert.: 19
[    56.979] (II) intel(0): Gamma: 2.20
[    56.979] (II) intel(0): DPMS capabilities: StandBy Suspend Off
[    56.979] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[    56.979] (II) intel(0): First detailed timing is preferred mode
[    56.979] (II) intel(0): redX: 0.569 redY: 0.332   greenX: 0.312 greenY: 0.544
[    56.979] (II) intel(0): blueX: 0.149 blueY: 0.132   whiteX: 0.313 whiteY: 0.329
[    56.979] (II) intel(0): Supported established timings:
[    56.979] (II) intel(0): 640x480@60Hz
[    56.979] (II) intel(0): 800x600@60Hz
[    56.979] (II) intel(0): 1024x768@60Hz
[    56.979] (II) intel(0): Manufacturer's mask: 0
[    56.980] (II) intel(0): Supported detailed timing:
[    56.980] (II) intel(0): clock: 69.5 MHz   Image Size:  303 x 190 mm
[    56.980] (II) intel(0): h_active: 1280  h_sync: 1332  h_sync_end 1396 h_blank_end 1416 h_border: 0
[    56.980] (II) intel(0): v_active: 800  v_sync: 803  v_sync_end 806 v_blanking: 818 v_border: 0
[    56.980] (II) intel(0): Supported detailed timing:
[    56.980] (II) intel(0): clock: 57.7 MHz   Image Size:  303 x 190 mm
[    56.980] (II) intel(0): h_active: 1280  h_sync: 1332  h_sync_end 1396 h_blank_end 1384 h_border: 0
[    56.980] (II) intel(0): v_active: 800  v_sync: 803  v_sync_end 806 v_blanking: 834 v_border: 0
[    56.980] (II) intel(0): Unknown vendor-specific block f
[    56.980] (II) intel(0):  LTN141AT10-G
[    56.980] (II) intel(0): EDID (in hex):
[    56.980] (II) intel(0):    00ffffffffffff0030ae314000000000
[    56.980] (II) intel(0):    00110103801e1378eacd7591554f8b26
[    56.980] (II) intel(0):    21505421080001010101010101010101
[    56.980] (II) intel(0):    010101010101261b0088502012303440
[    56.980] (II) intel(0):    33002fbe100000198b16006850202230
[    56.980] (II) intel(0):    344033002fbe100000190000000f0081
[    56.980] (II) intel(0):    0a32810a281201004ca35731000000fe
[    56.980] (II) intel(0):    004c544e313431415431302d470a00aa
[    56.980] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[    56.980] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[    56.980] (II) intel(0): Printing probed modes for output LVDS1
[    56.980] (II) intel(0): Modeline "1280x800"x60.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[    56.980] (II) intel(0): Modeline "1280x800"x49.5   57.71  1280 1332 1396 1397  800 803 806 834 -hsync -vsync (41.3 kHz e)
[    56.980] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    56.980] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    56.980] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[    56.980] (II) intel(0): Modeline "640x480"x60.0   25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    56.980] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[    56.987] (II) intel(0): EDID for output VGA1
[    56.991] (II) intel(0): EDID for output HDMI1
[    56.991] (II) intel(0): EDID for output DP1
[    57.000] (II) intel(0): EDID for output DP2
[    57.000] (II) intel(0): Output LVDS1 connected
[    57.000] (II) intel(0): Output VGA1 disconnected
[    57.000] (II) intel(0): Output HDMI1 disconnected
[    57.000] (II) intel(0): Output DP1 disconnected
[    57.000] (II) intel(0): Output DP2 disconnected
[    57.000] (II) intel(0): Using exact sizes for initial modes
[    57.000] (II) intel(0): Output LVDS1 using initial mode 1280x800
[    57.000] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    57.000] (II) intel(0): Kernel page flipping support detected, enabling
[    57.000] (==) intel(0): DPI set to (96, 96)
[    57.000] (II) Loading sub module "fb"
[    57.000] (II) LoadModule: "fb"
[    57.001] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[    57.019] (II) Module fb: vendor="X.Org Foundation"
[    57.019]    compiled for 1.17.4, module version = 1.0.0
[    57.019]    ABI class: X.Org ANSI C Emulation, version 0.4
[    57.019] (II) Loading sub module "dri2"
[    57.019] (II) LoadModule: "dri2"
[    57.019] (II) Module "dri2" already built-in
[    57.019] (II) UnloadModule: "vesa"
[    57.019] (II) Unloading vesa
[    57.019] (==) Depth 24 pixmap format is 32 bpp
[    57.020] (II) intel(0): [DRI2] Setup complete
[    57.020] (II) intel(0): [DRI2]   DRI driver: i965
[    57.020] (II) intel(0): Allocated new frame buffer 1280x800 stride 5120, tiled
[    57.037] (II) UXA(0): Driver registered support for the following operations:
[    57.037] (II)         solid
[    57.037] (II)         copy
[    57.037] (II)         composite (RENDER acceleration)
[    57.037] (II)         put_image
[    57.037] (II)         get_image
[    57.037] (==) intel(0): Backing store enabled
[    57.037] (==) intel(0): Silken mouse enabled
[    57.038] (II) intel(0): Initializing HW Cursor
[    57.038] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    57.047] (==) intel(0): DPMS enabled
[    57.047] (==) intel(0): Intel XvMC decoder enabled
[    57.047] (II) intel(0): Set up textured video
[    57.060] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[    57.060] (II) intel(0): direct rendering: DRI2 Enabled
[    57.097] (--) RandR disabled
[    57.342] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    57.342] (II) AIGLX: enabled GLX_ARB_create_context
[    57.342] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    57.342] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[    57.342] (II) AIGLX: enabled GLX_INTEL_swap_event
[    57.342] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    57.342] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    57.342] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    57.342] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    57.343] (II) AIGLX: Loaded and initialized i965
[    57.343] (II) GLX: Initialized DRI2 GL provider for screen 0
[    57.343] (II) intel(0): Setting screen physical size to 338 x 211
[    57.887] (II) config/devd: probing input devices...
[    57.887] (II) config/devd: adding input device (null) (/dev/kbdmux)
[    57.887] (II) LoadModule: "kbd"
[    57.887] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[    57.897] (II) Module kbd: vendor="X.Org Foundation"
[    57.897]    compiled for 1.17.2, module version = 1.8.1
[    57.897]    Module class: X.Org XInput Driver
[    57.897]    ABI class: X.Org XInput driver, version 21.0
[    57.897] (II) Using input driver 'kbd' for 'kbdmux'
[    57.897] (**) kbdmux: always reports core events
[    57.897] (**) kbdmux: always reports core events
[    57.898] (**) Option "Protocol" "standard"
[    57.898] (**) Option "XkbRules" "base"
[    57.898] (**) Option "XkbModel" "pc105"
[    57.898] (**) Option "XkbLayout" "us"
[    57.898] (**) Option "config_info" "devd:kbdmux"
[    57.898] (II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
[    57.921] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[    57.921] (II) config/devd: adding input device (null) (/dev/sysmouse)
[    57.921] (II) LoadModule: "mouse"
[    57.922] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[    57.938] (II) Module mouse: vendor="X.Org Foundation"
[    57.938]    compiled for 1.17.2, module version = 1.9.1
[    57.938]    Module class: X.Org XInput Driver
[    57.938]    ABI class: X.Org XInput driver, version 21.0
[    57.938] (II) Using input driver 'mouse' for 'sysmouse'
[    57.938] (**) sysmouse: always reports core events
[    57.938] (**) Option "Device" "/dev/sysmouse"
[    57.938] (==) sysmouse: Protocol: "Auto"
[    57.938] (**) sysmouse: always reports core events
[    57.938] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[    57.938] (**) sysmouse: ZAxisMapping: buttons 4 and 5
[    57.938] (**) sysmouse: Buttons: 5
[    57.938] (**) Option "config_info" "devd:sysmouse"
[    57.938] (II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
[    57.938] (**) sysmouse: (accel) keeping acceleration scheme 1
[    57.938] (**) sysmouse: (accel) acceleration profile 0
[    57.938] (**) sysmouse: (accel) acceleration factor: 2.000
[    57.938] (**) sysmouse: (accel) acceleration threshold: 4
[    57.938] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[    57.938] (II) sysmouse: SetupAuto: protocol is SysMouse
[    57.938] (II) config/devd: device /dev/psm0 already opened
[    63.519] (II) intel(0): EDID vendor "LEN", prod id 16433
[    63.519] (II) intel(0): Printing DDC gathered Modelines:
[    63.519] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[    63.519] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    63.520] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    63.520] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    72.357] (II) intel(0): EDID vendor "LEN", prod id 16433
[    72.357] (II) intel(0): Printing DDC gathered Modelines:
[    72.357] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[    72.357] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    72.357] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    72.357] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    96.869] (EE) intel(0): Detected a hung GPU, disabling acceleration.
[    96.869] (EE) intel(0): When reporting this, please include i915_error_state from debugfs and the full dmesg.
[    97.836] (II) intel(0): EDID vendor "LEN", prod id 16433
[    97.836] (II) intel(0): Printing DDC gathered Modelines:
[    97.836] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[    97.836] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    97.837] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    97.837] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    99.648] (II) intel(0): EDID vendor "LEN", prod id 16433
[    99.648] (II) intel(0): Printing DDC gathered Modelines:
[    99.648] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[    99.648] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    99.648] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    99.648] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   100.491] (II) intel(0): EDID vendor "LEN", prod id 16433
[   100.491] (II) intel(0): Printing DDC gathered Modelines:
[   100.491] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[   100.491] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   100.491] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   100.491] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   102.288] (II) intel(0): EDID vendor "LEN", prod id 16433
[   102.288] (II) intel(0): Printing DDC gathered Modelines:
[   102.288] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[   102.288] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   102.288] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   102.288] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   103.126] (II) intel(0): EDID vendor "LEN", prod id 16433
[   103.126] (II) intel(0): Printing DDC gathered Modelines:
[   103.126] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[   103.126] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   103.126] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   103.126] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   104.943] (II) intel(0): EDID vendor "LEN", prod id 16433
[   104.943] (II) intel(0): Printing DDC gathered Modelines:
[   104.943] (II) intel(0): Modeline "1280x800"x0.0   69.50  1280 1332 1396 1416  800 803 806 818 -hsync -vsync (49.1 kHz eP)
[   104.944] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   104.944] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   104.944] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   378.614] (II) config/devd: ignoring device umass0
[   453.828] (II) config/devd: ignoring device umass0


[E D I T:]
Just noticed that X picked up some settings from the config file, but I don't have one that I know of. I do have two xorg.conf files, one suffixed .orig and the other .vbox (I think). For whatever it may be worth.
Technologist. Writer and Editor. Shakespearean actor
Google Plus: http://google.com/+DanielEscasa
Twitter: @silverlokk

If we choose being kind over being right, we will be right every time.
descasa
 
Posts: 13
Joined: Wed Jun 11, 2014 6:10 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Successful install, unsuccessful upgrade

Postby ericbsd » Fri Dec 18, 2015 1:20 am

There is no upgrade to 10.2 unless you did an upgrade yourself to FreeBSD 10.2.

Can you look at /etc/devfs.rules if add path 'dri/*' mode 0666 group operator is in it. That might be the problem.

Also you can change gdm_enable="YES" to gdm_enable="NO" in /etc/rc.con using ee, nano, vi or vim reboot run startx to see if you get the black screen. You can run
Code: Select all
Xorg -configure
to generate a xorg.conf.new it will be generated under /root/ or /etc/X11/ copy it under /etc/X11/xorg.conf

You can type gdm in console to test it. If it work gdm_enable="YES" in /etc/rc.conf.

I hope this will help and I am sorry for those incontinent.
ericbsd
Developer
 
Posts: 1017
Joined: Mon Nov 19, 2012 11:54 pm
Has thanked: 18 times
Been thanked: 36 times

Re: Successful install, unsuccessful upgrade

Postby descasa » Fri Dec 18, 2015 2:54 am

Hi Eric, thanks for getting back to me. /etc/devfs.rules had group instead of operator, changed it to the latter, and I'm in GhostBSD now, in MATE.

As to the upgrade to 10.2, whatever pop-up and the subsequent upgrade did, it wasn't indeed to FreeBSD 10.2, as you might've seen in my Xorg.0.log. Wish I'd have taken a screen shot of that.

Gosh, that was easy, relatively anyway -- longer story below. Didn't have to go through editing /etc/rc.conf and disabling gdm.

Slightly longer story: ssh'ed into Ghost from my BeagleBone Black and modified /etc/devfs.rules from there. I couldn't switch to console in Ghost, a minor inconvenience at the moment, which is why I resorted to the BBB route.

Thanks again.
Technologist. Writer and Editor. Shakespearean actor
Google Plus: http://google.com/+DanielEscasa
Twitter: @silverlokk

If we choose being kind over being right, we will be right every time.
descasa
 
Posts: 13
Joined: Wed Jun 11, 2014 6:10 pm
Has thanked: 0 time
Been thanked: 0 time

Re: Successful install, unsuccessful upgrade

Postby ericbsd » Fri Dec 18, 2015 10:13 am

By the way if you want to know at what version you are freebsd-version in Mate Terminal.
ericbsd
Developer
 
Posts: 1017
Joined: Mon Nov 19, 2012 11:54 pm
Has thanked: 18 times
Been thanked: 36 times

Re: Successful install, unsuccessful upgrade

Postby Daisy22 » Mon Feb 13, 2017 10:54 am

Hello guys! please help me my ghostbsd not installed what to do ?
Daisy22
 
Posts: 1
Joined: Mon Feb 13, 2017 10:48 am
Has thanked: 0 time
Been thanked: 0 time


Return to Installing GhostBSD

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron