How can I enable the backlight and sound system

Need support for GhostBSD. Ask here if your question does not fit elsewhere.

How can I enable the backlight and sound system

Postby joachin » Wed Aug 23, 2017 6:54 pm

Hello, I have ghostbs 11.1 and its all ok, but when I try to test the brightness (with the keys on the laptop) I can't, and I don't have sound, I can't watch youtube, play music or something like that.

Hope you can help me, first tiem with BSD.

Thanks
joachin
 
Posts: 6
Joined: Wed Aug 23, 2017 6:51 pm
Has thanked: 0 time
Been thanked: 0 time

How can I enable the backlight and sound system


Re: How can I enable the backlight and sound system

Postby ASX » Thu Aug 24, 2017 5:41 am

what laptop is that ?
anyway, may be you need to load some acpi module, like acpi_video.ko

edit:
about sound, try the command mixer from a terminal, additionally install/run pavucontrol
ASX
 
Posts: 988
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 133 times

Re: How can I enable the backlight and sound system

Postby NevilleGoddard » Thu Aug 24, 2017 9:17 am

Also, what is the output of cat /dev/sndstat ?

This shows all the available sound devices. Perhaps the wrong default sound device is being used.

On my machine I have installed a sound card and when I install GhostBSD I also have no sound as the OS defaults to the on board sound and I have to choose the default device to use for each boot.

For example on my machine the output of cat /dev/sndstat is:

Installed devices:
pcm0: <NVIDIA (0x0042) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0042) (HDMI/DP 8ch)> (play)
pcm2: <NVIDIA (0x0042) (HDMI/DP 8ch)> (play)
pcm3: <NVIDIA (0x0042) (HDMI/DP 8ch)> (play)
pcm4: <Realtek ALC887 (Rear Analog)> (play/rec)
pcm5: <Realtek ALC887 (Front Analog)> (play/rec)
pcm6: <Realtek ALC887 (Internal Digital)> (play)
pcm7: <Envy24HT audio (Generic)> (play/rec) default
No devices installed from userspace.

When you install GhostBSD, the default device will probably be pcm0 so the sound will go through in this case the nvidia device.

I want sound through my installed card which is:

pcm7: <Envy24HT audio (Generic)> (play/rec) default

As you can see it says default after it because I have made it default, but a fresh install will have pcm0 default.

To make pcm7 default I had to edit a file called /etc/sysctl.conf with the following command (as root):

ee /etc/sysctl.conf

then add the following line to the bottom of the file:

hw.snd.default_unit=7

I use unit=7 because pcm7 is the device I want to use.

save the file by pressing the Esc key and then the Enter key when prompted and rebooting and then I have sound.

On your laptop, find out the default device i.e. the device to which there in the word default next to.

Typically the default device should be this one:


pcm4: <Realtek ALC887 (Rear Analog)> (play/rec) Obviously yours could be pcm1 or pcm0, not pcm4

On my laptop cat /dev/sndstat gives:

pcm0: <Realtek ALC268 (Analog 2.0+HP/2.0)> (play/rec) default

So the sound card is Realtek ALC268. See what yours is and let us know.
NevilleGoddard
Developer
 
Posts: 377
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 77 times
Been thanked: 53 times

Re: How can I enable the backlight and sound system

Postby joachin » Thu Aug 24, 2017 12:19 pm

Thanks for your answer, when I do mixer, I have the following answer:
Mixer vol is currently set to 85:85
Mixer pcm is currently set to 100:100
Mixer speaker is currently set to 74:74
Mixer rec is currently set to 37:37
Mixer igain is currently set to 0:0
Mixer ogain is currently set to 100:100
Mixer monitor is currently set to 67:67
Recording source: monitor

Pavucontrol in Configuration section says:
no cards available for configuration.

The cat /dev/sndstat says
Installed devices:
pcm0: <Realtek ALC255 (Internal Analog)> (play/rec) default
pcm1: <Realtek ALC255 (Front Analog Headphones)> (play)
pcm2: <Intel (0x2883) (HDMI/DP 8ch)> (play)
No devices installed from userspace.
joachin
 
Posts: 6
Joined: Wed Aug 23, 2017 6:51 pm
Has thanked: 0 time
Been thanked: 0 time

Re: How can I enable the backlight and sound system

Postby NevilleGoddard » Sat Aug 26, 2017 10:27 pm

do the commands

mixer

then:

mixer igain 100:100

help?
NevilleGoddard
Developer
 
Posts: 377
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 77 times
Been thanked: 53 times

Re: How can I enable the backlight and sound system

Postby joachin » Sun Aug 27, 2017 9:31 pm

I did it and still have no sound
joachin
 
Posts: 6
Joined: Wed Aug 23, 2017 6:51 pm
Has thanked: 0 time
Been thanked: 0 time

Re: How can I enable the backlight and sound system

Postby joachin » Sat Sep 23, 2017 11:37 am

It's a dell inspiron 15 5100 with Intel Celeron N3060, this is my pciconf: https://pastebin.com/kVCL1vjk
joachin
 
Posts: 6
Joined: Wed Aug 23, 2017 6:51 pm
Has thanked: 0 time
Been thanked: 0 time

Re: How can I enable the backlight and sound system

Postby NevilleGoddard » Sat Sep 23, 2017 11:33 pm

This shouldn't be necessary but try as root:

kldload snd_driver

if that doesn't work try putting in /boot/loader.conf (if you're not using grub)

snd_driver_load="YES"

and rebooting


Does the sound come through the headphones? I once thought I lost sound until I plugged in my headphones and found out that my speaker volume control knob on the actual speakers was broken but sound came out fine through my headphones.

Also do you get sound testing with GhostBSD 10.3 or Ubuntu live cd/usb ?

Have you tried a reinstall? Perhaps your sound got broken somehow in the install process.
NevilleGoddard
Developer
 
Posts: 377
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 77 times
Been thanked: 53 times

Re: How can I enable the backlight and sound system

Postby ASX » Sun Sep 24, 2017 4:25 am

joachin wrote:It's a dell inspiron 15 5100 with Intel Celeron N3060, this is my pciconf: https://pastebin.com/kVCL1vjk


Your Intel graphics might not be supported in fbsd11, but it is in fbsd12-current:
https://forums.freebsd.org/threads/62120/

you might have better luck with TrueOS, which is based on fbsd12-current.

same fore sound evedently:
https://forums.freebsd.org/threads/62325/#post-361486
ASX
 
Posts: 988
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 133 times

Re: How can I enable the backlight and sound system

Postby joachin » Sun Sep 24, 2017 9:10 am

Thanks I read it, the last post it's mine, I installed TrueOS and I have sound there! But I want to have FreeBSD or GhostBSD, I think if TrueOS has sound, I can have it too in FreeBSD Current.
joachin
 
Posts: 6
Joined: Wed Aug 23, 2017 6:51 pm
Has thanked: 0 time
Been thanked: 0 time

Next

Return to General support

Who is online

Users browsing this forum: No registered users and 1 guest

cron