nvidia-xconfig

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
User avatar
galasrinnion
Posts: 39
Joined: Tue Oct 28, 2014 12:45 pm
Has thanked: 0
Been thanked: 0

nvidia-xconfig

Post by galasrinnion » Fri Mar 11, 2016 3:42 pm

Hello

While installing nvidia drivers through octopkg and adjusting scripts in/etc/defaults/rc.conf and /boot/device.hints I overlooked the last step nvidia-xconfig !
so I cannot boot into the graphics just getting an ooops screen try again, with no success.
Can i get fix this or have I borked it and need to reinstall

zhaich
Posts: 2
Joined: Fri Mar 11, 2016 11:53 pm
Has thanked: 0
Been thanked: 0

Re: nvidia-xconfig

Post by zhaich » Fri Mar 11, 2016 11:58 pm

I had the exact same problem recently.
Do Ctrl-Alt-F2 at the oops screen. Login as root and there type

Code: Select all

nvidia-xconfig
then reboot.

User avatar
galasrinnion
Posts: 39
Joined: Tue Oct 28, 2014 12:45 pm
Has thanked: 0
Been thanked: 0

Re: nvidia-xconfig

Post by galasrinnion » Sat Mar 12, 2016 4:17 pm

Thanks for the help, however I can't even get in to the OOPS! screen now. Getting bad files messages during the boot-up message scroll. then it just wants to reboot. So...must have borked the files somehow too !

User avatar
galasrinnion
Posts: 39
Joined: Tue Oct 28, 2014 12:45 pm
Has thanked: 0
Been thanked: 0

Re: nvidia-xconfig

Post by galasrinnion » Thu Mar 17, 2016 2:18 am


zhaich
Posts: 2
Joined: Fri Mar 11, 2016 11:53 pm
Has thanked: 0
Been thanked: 0

Re: nvidia-xconfig

Post by zhaich » Thu Mar 17, 2016 12:57 pm

galasrinnion wrote:Thanks for the help, however I can't even get in to the OOPS! screen now. Getting bad files messages during the boot-up message scroll. then it just wants to reboot. So...must have borked the files somehow too !
Sounds like more got corrupted than simply xorg.conf. I would boot up a live DVD and login as root at the cli. Type in as root

Code: Select all

nvidia-xconfig
which automatically generates a new xorg.conf around the NVIDIA driver and reboot to see if that helps. I would also check your logs for those errors that you saw on boot up. Hope that helps.

User avatar
galasrinnion
Posts: 39
Joined: Tue Oct 28, 2014 12:45 pm
Has thanked: 0
Been thanked: 0

Re: nvidia-xconfig

Post by galasrinnion » Sat Mar 26, 2016 6:46 pm

I reinstalled and back to KICK ###

Post Reply