About conversion of Japanese

Need support for GhostBSD. Ask here if your question does not fit elsewhere.

About conversion of Japanese

Postby usuha » Sun Aug 13, 2017 10:57 am

Hello.
I am using "GhostBSD 11.1 MATE".
I installed "ja-ibus-mozc" of Japanese conversion software.

I am adding (editing) to ~/.xinitrc file as follows.
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=xim
export XMODIFIERS=@im=ibus
/usr/local/bin/mozc
start
ibus-daemon -r --daemonize --xim

However, it is not possible to convert Japanese.
If anyone knows how to solve this problem, please give me a professor.
User avatar
usuha
 
Posts: 7
Joined: Sun Aug 13, 2017 10:37 am
Location: Tokyo, Japan
Has thanked: 0 time
Been thanked: 0 time

About conversion of Japanese


Re: About conversion of Japanese

Postby ASX » Sun Aug 13, 2017 2:29 pm

I'm not using scim or ibus myself, but a friend suggested me the following:

Code: Select all
#in .xinitrc

export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE="xim"
export QT_IM_MODULE="scim"
scim -d


Note also that "ja-ibus-mozc" currently has no maintainer in FreeBSD ports, so that might be part of the problem.

Hope that help!
ASX
 
Posts: 988
Joined: Wed May 06, 2015 11:46 am
Has thanked: 58 times
Been thanked: 132 times

Re: About conversion of Japanese

Postby usuha » Sun Aug 13, 2017 10:24 pm

Thanks a lot ASX.

I have installed "ja-scim-anthy" as well.
"SCIM-Anthy" has been able to convert Japanese without setting anything in particular.

Many thanks.
User avatar
usuha
 
Posts: 7
Joined: Sun Aug 13, 2017 10:37 am
Location: Tokyo, Japan
Has thanked: 0 time
Been thanked: 0 time

Re: About conversion of Japanese

Postby NevilleGoddard » Mon Aug 14, 2017 7:20 am

I'm using ja-ibus-anthy and it works perfectly.

On xfce nothing in .xinitrc is required and I use the zenkaku/hankaku key to change from Japanese to English and back.
NevilleGoddard
Developer
 
Posts: 355
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 76 times
Been thanked: 46 times

Re: About conversion of Japanese

Postby usuha » Mon Aug 14, 2017 12:17 pm

Thanks a lot NevilleGoddard.

That is very nice information.
"ja-ibus-anthy" is perfectly working.
Regarding the setting, it is displayed as a message at the time of installation.
My "ja-ibus-mozc" does not work well yet.

Thank you very much.
Last edited by usuha on Tue Aug 15, 2017 11:31 am, edited 1 time in total.
User avatar
usuha
 
Posts: 7
Joined: Sun Aug 13, 2017 10:37 am
Location: Tokyo, Japan
Has thanked: 0 time
Been thanked: 0 time

Re: About conversion of Japanese

Postby usuha » Mon Aug 14, 2017 6:20 pm

I installed "ja-ibus-anthy".

The following message was displayed.
ibus-anthy installation finished. To use ibus-anthy, please do the following:
If you are using bash or zsh, please add following lines to your $HOME/.bashrc or
$HOME/.zshrc:
export XIM=ibus
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=xim
export XMODIFIERS=@im=ibus
export XIM_PROGRAM="ibus-daemon"
export XIM_ARGS="-r --daemonize --xim"

user $ sudo nano ~/.bashrc
export XIM=ibus
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=xim
export XMODIFIERS=@im=ibus
export XIM_PROGRAM="ibus-daemon"
export XIM_ARGS="-r --daemonize --xim"

user $ sudo reboot

"ja-ibus-anthy" did not convert Japanese.
User avatar
usuha
 
Posts: 7
Joined: Sun Aug 13, 2017 10:37 am
Location: Tokyo, Japan
Has thanked: 0 time
Been thanked: 0 time

Re: About conversion of Japanese

Postby NevilleGoddard » Mon Aug 14, 2017 10:04 pm

You have to open a terminal and run ibus-setup
NevilleGoddard
Developer
 
Posts: 355
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 76 times
Been thanked: 46 times

Re: About conversion of Japanese

Postby NevilleGoddard » Tue Aug 15, 2017 7:58 am

Here's a quick start guide to Japanese input on GhostBSD.

Install the following using OctoPkg:

ja-ibus-anthy - This will pull in all the necessary packages for Japanese input

ja-font-takao - Nicer looking fonts but not otherwise necessary.

reboot your machine.

Go to your applications menu and search for IBus-Preferences and launch it. Or open a terminal and a user enter "ibus-setup".

Don't do any editing of .xinitrc - not yet anyway.

In the IBus Preferences window click on the "Input Methods" tab at the top in the middle. You should already have "Japanese-Japanese" in the input window in you are using a Japanese keyboard. If you have a US keyboard it will probably show English (US) or something like that. You now have to add your Japanese input for the keyboard to use.

Then click "Add".

Then scroll down until you see "Japanese". Then click on it.

Select " Aち Anthy". Then click "Add".

Now you should have 2 input methods- Japanese-Japanese and Aち- Japanese- Anthy.

Now click the "General" tab on the top left.

It will show the method (hot keys) to switch from English to Japanese on the top next to "Next Input Method". I think the default is Ctrl + Space. You can keep these and start using anthy now to type Japanese, but I prefer to use the proper Zenkaku/Hankaku key on my Japanese keyboard.

To change from the default Ctrl+Space to Zenkaku/Hankaku, clisk on the 3 dots next to the bar showing the input method.

In the middle of the window that pops up there will be a Key Code section with a bar showing the Hot Keys. Click on the 3 dots to the right of this.

A window will pop up and in the middle will be a bar that says "Disabled". Click on the "Disabled" bar and press the zenkaku/hankaku button. The window will disappear and you will be back to the previous window . In this window click the "Add" button to add the zenkaku/hankaku shortcut. To get rid of the default shortcut key combination, click on the default entry under "Keyboard Shortcuts" and press the "Delete" button. Then click OK.

Then close IBus-Preferences and try your (日本語入力) Japanese Input. :D
NevilleGoddard
Developer
 
Posts: 355
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 76 times
Been thanked: 46 times

Re: About conversion of Japanese

Postby usuha » Tue Aug 15, 2017 10:53 am

Thanks a lot NevilleGoddard.

It will show the method (hot keys) to switch from English to Japanese on the top next to "Next Input Method". I think the default is Ctrl + Space.

My settings
IBUS-anthy "Next Input Method" Super + Space
SCIM-anthy "Next Input Method" Ctrl + Space

Many thanks.

https://cdn.scrot.moe/images/2017/12/04 ... h38_42.png
Last edited by usuha on Sun Dec 03, 2017 11:08 am, edited 7 times in total.
User avatar
usuha
 
Posts: 7
Joined: Sun Aug 13, 2017 10:37 am
Location: Tokyo, Japan
Has thanked: 0 time
Been thanked: 0 time

Re: About conversion of Japanese

Postby NevilleGoddard » Tue Aug 15, 2017 11:20 am

Glad I could help.

Nice wallpaper.

Welcome to GhostBSD from Chiba! :D
NevilleGoddard
Developer
 
Posts: 355
Joined: Thu Dec 22, 2016 10:30 pm
Has thanked: 76 times
Been thanked: 46 times


Return to General support

Who is online

Users browsing this forum: No registered users and 1 guest

cron